OSPF Practice

Lab Diagram

172.16.1.0\24

172.16.3.0\24

172.16.2.0\24

209.168.1.0\30

192.168.2.0\24

192.168.3.0\24

Lab Objectives

  • Cable a network in accordance with the diagram given
  • Configure the hostname and interface IP addresses, or paste the initial configuration onto all devices
  • Ensure that R1's router-id will always be set to 1.1.1.1, without he use of the router-id command
  • Ensure that R2's router-id will always be set to 2.2.2.2, without he use of the router-id command
  • Router R3 should have its router-id set to 3.3.3.3 using the router-id command
  • Enable OSPF on all interfaces
  • NOTE: R1's Fa0/0 interface should not be a part of the OSPF process at all
  • Adjacencies should not be formed on any ethernet interfaces, but their networks should still be advertised by OSPF
  • Configure a default route on R1 to the ISP router (209.168.1.2)
  • By only changing the configuration on R1, ensure that all other routers will treat R1 as their gateway of last resort

Initial Configuration

Show/Hide
R1R2R3
  • !Configuration generated by CCNAPractice.com
  • !
  • !
  • hostname R1
  • !
  • !
  • !
  • !
  • interface Serial0/0
  •  ip address 172.16.1.1 255.255.255.0
  •  clock rate 64000
  •  no shutdown
  • !
  • interface Serial0/1
  •  ip address 172.16.3.1 255.255.255.0
  •  no shutdown
  • !
  • interface FastEthernet0/0
  •  ip address 209.168.1.1 255.255.255.252
  •  no shutdown
  • !
  • !
  • line con 0
  • !
  • end
  •  
  • !Configuration generated by CCNAPractice.com
  • !
  • !
  • hostname R2
  • !
  • !
  • !
  • !
  • interface Serial0/0
  •  ip address 172.16.2.1 255.255.255.0
  •  clock rate 64000
  •  no shutdown
  • !
  • interface Serial0/1
  •  ip address 172.16.1.2 255.255.255.0
  •  no shutdown
  • !
  • interface FastEthernet0/0
  •  ip address 192.168.2.1 255.255.255.0
  •  no shutdown
  • !
  • !
  • line con 0
  • !
  • end
  •  
  • !Configuration generated by CCNAPractice.com
  • !
  • !
  • hostname R3
  • !
  • !
  • !
  • !
  • interface Serial0/0
  •  ip address 172.16.3.2 255.255.255.0
  •  clock rate 64000
  •  no shutdown
  • !
  • interface Serial0/1
  •  ip address 172.16.2.2 255.255.255.0
  •  no shutdown
  • !
  • interface FastEthernet0/0
  •  ip address 192.168.3.1 255.255.255.0
  •  no shutdown
  • !
  • !
  • line con 0
  • !
  • end
  •  

Final Configuration

Show/Hide
R1R2R3
  • !Configuration generated by CCNAPractice.com
  • !
  • !
  • hostname R1
  • !
  • !
  • !
  • !
  • interface Loopback1
  •  ip address 1.1.1.1 255.255.255.255
  •  no shutdown
  • !
  • interface Serial0/0
  •  ip address 172.16.1.1 255.255.255.0
  •  clock rate 64000
  •  no shutdown
  • !
  • interface Serial0/1
  •  ip address 172.16.3.1 255.255.255.0
  •  no shutdown
  • !
  • interface FastEthernet0/0
  •  ip address 209.168.1.1 255.255.255.252
  •  no shutdown
  • !
  • ip route 0.0.0.0 0.0.0.0 209.168.1.2
  • !
  • router ospf 30
  •  network 172.16.1.0 0.0.0.255 area 0
  •  network 172.16.3.0 0.0.0.255 area 0
  •  default-information originate
  • !
  • line con 0
  • !
  • end
  •  
  • !Configuration generated by CCNAPractice.com
  • !
  • !
  • hostname R2
  • !
  • !
  • !
  • !
  • interface Loopback1
  •  ip address 2.2.2.2 255.255.255.255
  •  no shutdown
  • !
  • interface Serial0/0
  •  ip address 172.16.2.1 255.255.255.0
  •  clock rate 64000
  •  no shutdown
  • !
  • interface Serial0/1
  •  ip address 172.16.1.2 255.255.255.0
  •  no shutdown
  • !
  • interface FastEthernet0/0
  •  ip address 192.168.2.1 255.255.255.0
  •  no shutdown
  • !
  • !
  • router ospf 50
  •  passive-interface FastEthernet0/0
  •  network 172.16.2.0 0.0.0.255 area 0
  •  network 172.16.1.0 0.0.0.255 area 0
  •  network 192.168.2.0 0.0.0.255 area 0
  • !
  • line con 0
  • !
  • end
  •  
  • !Configuration generated by CCNAPractice.com
  • !
  • !
  • hostname R3
  • !
  • !
  • !
  • !
  • interface Serial0/0
  •  ip address 172.16.3.2 255.255.255.0
  •  clock rate 64000
  •  no shutdown
  • !
  • interface Serial0/1
  •  ip address 172.16.2.2 255.255.255.0
  •  no shutdown
  • !
  • interface FastEthernet0/0
  •  ip address 192.168.3.1 255.255.255.0
  •  no shutdown
  • !
  • !
  • router ospf 10
  •  router-id 3.3.3.3
  •  passive-interface FastEthernet0/0
  •  network 172.16.3.0 0.0.0.255 area 0
  •  network 172.16.2.0 0.0.0.255 area 0
  •  network 192.168.3.0 0.0.0.255 area 0
  • !
  • line con 0
  • !
  • end
  •  

2 thoughts on “OSPF Practice

  1. Leah

    QQ–In R1 you have listed that the OSPF instance is 40 yet the other 2 say 50. Is there a reason or is it a typo? I thought it had to be same instance.

    Thanks

    Reply
    1. stuart Post author

      Hi Leah,

      The OSPF instance numbers are only locally significant, so they can differ or be the same between routers.

      Reply

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>