OSPF IPv4 Lab Open Shortest Path First

Lab Diagram

172.16.1.0\24

172.16.3.0\24

172.16.2.0\24

209.168.1.0\30

192.168.2.0\24

192.168.3.0\24

Lab Objectives

  • Cable a network in accordance with the diagram given
  • Configure the hostname and interface IP addresses, or paste the initial configuration onto all devices
  • Change the router-id of R1 to 1.1.1.1 without using the router-id command, and ensure that it will always be set to this on start up
  • Explicitly set the router-id of R2 to 2.2.2.2
  • Change the router-id of R3 to 3.3.3.3 without using the router-id command, and ensure that it will always be set to this on start up
  • Ensure that all routers form adjacencies with each other
  • NOTE: R1's Fa0/0 interface should not be a part of the OSPF process at all
  • Adjacencies should not be formed on any ethernet interfaces, but their networks should still be advertised by OSPF
  • Without changing any other area of the configuration of R1, configure OSPF to distribute a default route to other routers

Initial Configuration (Already applied to devices in console)

R1 R2 R3
!Configuration generated by CCNAPractice.com 
!
!
hostname R1
!
!
!
!
interface Serial0/0
 ip address 172.16.1.1 255.255.255.0
 clock rate 64000
 no shutdown
!
interface Serial0/1
 ip address 172.16.3.1 255.255.255.0
 no shutdown
!
interface FastEthernet0/0
 ip address 209.168.1.1 255.255.255.252
 no shutdown
!
!
!
!
!
!
line con 0
!
end

!Configuration generated by CCNAPractice.com 
!
!
hostname R2
!
!
!
!
interface Serial0/0
 ip address 172.16.2.1 255.255.255.0
 clock rate 64000
 no shutdown
!
interface Serial0/1
 ip address 172.16.1.2 255.255.255.0
 no shutdown
!
interface FastEthernet0/0
 ip address 192.168.2.1 255.255.255.0
 no shutdown
!
!
!
!
!
!
line con 0
!
end

!Configuration generated by CCNAPractice.com 
!
!
hostname R3
!
!
!
!
interface Serial0/0
 ip address 172.16.3.2 255.255.255.0
 clock rate 64000
 no shutdown
!
interface Serial0/1
 ip address 172.16.2.2 255.255.255.0
 no shutdown
!
interface FastEthernet0/0
 ip address 192.168.3.1 255.255.255.0
 no shutdown
!
!
!
!
!
!
line con 0
!
end

Final Configuration

R1 R2 R3
!Configuration generated by CCNAPractice.com 
!
!
hostname R1
!
!
!
!
interface Loopback1
 ip address 1.1.1.1 255.255.255.255
 no shutdown
!
interface Serial0/0
 ip address 172.16.1.1 255.255.255.0
 clock rate 64000
 no shutdown
!
interface Serial0/1
 ip address 172.16.3.1 255.255.255.0
 no shutdown
!
interface FastEthernet0/0
 ip address 209.168.1.1 255.255.255.252
 no shutdown
!
!
!
!
!
!
router ospf 20
 network 172.16.1.0 0.0.0.255 area 0
 network 172.16.3.0 0.0.0.255 area 0
 default-information originate always
!
line con 0
!
end

!Configuration generated by CCNAPractice.com 
!
!
hostname R2
!
!
!
!
interface Serial0/0
 ip address 172.16.2.1 255.255.255.0
 clock rate 64000
 no shutdown
!
interface Serial0/1
 ip address 172.16.1.2 255.255.255.0
 no shutdown
!
interface FastEthernet0/0
 ip address 192.168.2.1 255.255.255.0
 no shutdown
!
!
!
!
!
!
router ospf 30
 router-id 2.2.2.2
 passive-interface FastEthernet0/0
 network 172.16.2.0 0.0.0.255 area 0
 network 172.16.1.0 0.0.0.255 area 0
 network 192.168.2.0 0.0.0.255 area 0
!
line con 0
!
end

!Configuration generated by CCNAPractice.com 
!
!
hostname R3
!
!
!
!
interface Loopback1
 ip address 3.3.3.3 255.255.255.255
 no shutdown
!
interface Serial0/0
 ip address 172.16.3.2 255.255.255.0
 clock rate 64000
 no shutdown
!
interface Serial0/1
 ip address 172.16.2.2 255.255.255.0
 no shutdown
!
interface FastEthernet0/0
 ip address 192.168.3.1 255.255.255.0
 no shutdown
!
!
!
!
!
!
router ospf 10
 passive-interface FastEthernet0/0
 network 172.16.3.0 0.0.0.255 area 0
 network 172.16.2.0 0.0.0.255 area 0
 network 192.168.3.0 0.0.0.255 area 0
!
line con 0
!
end


R1#
R2#
R3#

Comments